Need help! 1998 Low beams not working - Ford Explorer Forum - Forums for Ford Explorer Enthusiasts
Ford Explorer Forum - Forums for Ford Explorer Enthusiasts


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 08-02-2014, 11:26 PM   #1
Buford
Junior Member
 
Join Date: Aug 2014
Posts: 4
Need help! 1998 Low beams not working

My low beams stopped working. The high beams are working fine. I changed the bulbs and checked the fuses. Can anyone point me to a video of how to fix this?

Buford is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-03-2014, 08:47 PM   #2
Buford
Junior Member
 
Join Date: Aug 2014
Posts: 4
Hello All,

I figured out what the problem was. My multi-fuction switch on my steering wheel was bad. I wish I had been able to find a video on how to fix it. I just didn't feel comfortable doing it without pictures. Please someone friend me so I don't go broke. It would be great to find someone with more experience and knowledge for advice.
Buford is offline   Reply With Quote
Old 08-08-2014, 11:54 AM   #3
Stillaford
Site Team
 
Stillaford's Avatar
 
Join Date: Apr 2005
Location: Arizona
Posts: 4,669
They're really easy just take apart the clam shell on the column and it's very obvious how to replace. YOu may need to adjust the column down all the way to have enough clearance and move the gear selector but I did one myself back in '03 with no prior knowledge and it took me maybe 30 mins.
__________________
"Artists who seek perfection in everything are those who cannot attain it in anything."

- Eugene Delacroix (1798 - 1863)
Stillaford is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-03-2017, 10:57 AM   #4
susanao111
Junior Member
 
Join Date: May 2017
Posts: 5
Quote:
Originally Posted by Stillaford View Post
They're really easy just take apart the clam shell on the column and it's very obvious how to replace. YOu may need to adjust the column down all the way to have enough clearance and move the gear selector but I did one myself back in '03 with no prior knowledge and it took me maybe 30 mins.
Hi. Could you explain how you got your low beams to work again. I'm having this same problem on my 2002 Ford Explorer XLT. I just replaced my original steering column with one I bought from ebay at Schram auto parts and everything works fine except the low beams don't go on.

By the way I love your Delacroix quote. I am an artist and spend many a hour reading Delacroix journal and letters and looking at his work in books and in real life.

Thanks,
susan
susanao111 is offline   Reply With Quote
Reply

Tags
headlights, low beams, switch

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
low beams not working. Not a fuse issue X98limitedX 2nd Generation Explorers | 1995-2001 12 08-03-2017 10:35 AM
Low beams not working cellvian106 2nd Generation Explorers | 1995-2001 7 08-03-2017 10:01 AM
Explorer 1996 Low Beams Problem gosorioz 2nd Generation Explorers | 1995-2001 2 01-28-2014 09:22 AM
Low MPG, and low power RVD360 3rd Generation Explorers | 2002-2005 6 06-12-2012 08:15 PM
Auto door lock slow to respond/not working Rob 2nd Generation Explorers | 1995-2001 17 06-11-2007 03:53 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 04:37 AM.


ExplorerTalk.com is in no way associated with or endorsed by Ford Motor Company.

 

Content Relevant URLs by vBSEO 3.6.0