Reverse sensing system problem - Ford Explorer Forum - Forums for Ford Explorer Enthusiasts
Ford Explorer Forum - Forums for Ford Explorer Enthusiasts


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 03-21-2013, 05:42 PM   #1
jwisejr
Junior Member
 
Join Date: Mar 2013
Posts: 1
Reverse sensing system problem

as of lately the dash switch keeps going to "off" on its own. When I try to engage the switch it pops back to "off" again; what is going on ? Ref: 2003 Explorer XLT

jwisejr is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-22-2017, 04:15 PM   #2
J_C
Senior Member
 
Join Date: Apr 2016
Posts: 481
I'm not familiar with the switch for that, is it something that mechanically catches then is supposed to be pushed again to be turned off, or is it only a momentary type switch and by "off" you mean the function is off, not the switch position or light for it (whichever) ?

I would pull the switch out, substitute a (random, whatever I could get cheap) switch of the same type (momentary or latching and same # of poles) to see if it works right, before committing to finding and buying a exact replacement switch.

Then again I have a lot of switches from my electronics projects, if I didn't then I might see if a local junkyard had a vehicle with one, that vehicle being one still closed up with doors/windows/windshield/etc still so rain hadn't potentially corroded things like interior switches.

Sometimes if you're good at microsurgery you can pop a switch open and check its integrity, clean contacts, lube it, whatever, though more and more often in recent years they are molded together and the plastic has gotten brittle with age so it's getting rarer to be able to service one.
__________________
Please post your vehicle year/model/engine/(n)WD in help topics.

'98 Explorer XLT 4L SOHC 4WD
'14 Explorer XLT 3.5L NA AWD
J_C is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Reverse Sensing System malfunction myranger17 3rd Generation Explorers | 2002-2005 1 03-21-2012 06:08 AM
Speed sensing wire on a 2nd gen? T-Bolt Audio / Video / Security 0 07-26-2009 10:48 AM
Reverse sensing problem Killabee09 3rd Generation Explorers | 2002-2005 10 06-06-2007 05:52 PM
THE REVERSE GLO GAUGES ARE IN Fordexplorer157 2nd Generation Explorers | 1995-2001 6 12-29-2003 09:40 PM
Reverse Glow Gauges problem 2nd Generation Explorers | 1995-2001 0 12-31-1969 07:00 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 04:57 AM.


ExplorerTalk.com is in no way associated with or endorsed by Ford Motor Company.

 

Content Relevant URLs by vBSEO 3.6.0