2004 Explorer Sport Trac - Ford Explorer Forum - Forums for Ford Explorer Enthusiasts
Ford Explorer Forum - Forums for Ford Explorer Enthusiasts


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 10-20-2019, 09:47 AM   #1
lambchop49
Junior Member
 
Join Date: May 2018
Posts: 1
2004 Explorer Sport Trac

Help! My truck was running fine, then next time I started it, it ran for about 30 seconds then died, then it won't start at all. Then I noticed the low fuel light came on, so I added more gas and has done the same thing. It ran for about 20 seconds then won't fire at all. Any suggestions would be helpful.

lambchop49 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-22-2019, 06:09 PM   #2
J_C
Senior Member
 
Join Date: Apr 2016
Posts: 985
I'd check the fuel pressure. Are you getting any OBDII trouble codes?
__________________
Please post your vehicle year/model/engine/(n)WD in help topics.

'98 Explorer XLT 4L SOHC 4WD
'14 Explorer XLT 3.5L NA AWD
J_C is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 08:52 AM.


vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

ExplorerTalk.com is in no way associated with or endorsed by Ford Motor Company.

 

Content Relevant URLs by vBSEO 3.6.0