Change oil soon reset - Page 2 - Ford Explorer Forum - Forums for Ford Explorer Enthusiasts
Ford Explorer Forum - Forums for Ford Explorer Enthusiasts

Go Back   Ford Explorer Forum - Forums for Ford Explorer Enthusiasts > ExplorerX Generations > 3rd Generation Explorers | 2002-2005
Register FAQ Community Calendar Today's Posts Advertise

Reply
 
Thread Tools Search this Thread Display Modes
 
Old 01-01-2020, 05:52 PM   #11
RB2005XLT
Junior Member
 
Join Date: Mar 2017
Posts: 3
Since my last post (Nov 5th) haven't had the errant message pop up. Did an oil change today and reset the oil life to 100%. Shut down and did a restart - no message and oil life still shows 100%. From your original post gmcgann it sounds like you're getting the message immediately after a successful reset - mine didn't start going stupid until I was about 3K into the 5K interval and now it seems to be behaving. I'll see what happens when I get close to the 3K mileage on this change. You may have a computer glitch - maybe the PO tried to flash the computer with an upgrade and it BUFU'd the oil monitor part of the computer. If the PO changed the throttle body it may have required a flash of the computer and since these rigs are Flex Fuel rated who knows what that might do?

RB2005XLT is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply


Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 08:21 AM.


vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.

ExplorerTalk.com is in no way associated with or endorsed by Ford Motor Company.

 

Content Relevant URLs by vBSEO 3.6.0