Heater blend door not moving - Ford Explorer Forum - Forums for Ford Explorer Enthusiasts
Ford Explorer Forum - Forums for Ford Explorer Enthusiasts


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 09-30-2019, 10:20 AM   #1
Ron
Junior Member
 
Join Date: Apr 2019
Posts: 3
Heater blend door not moving

On my 2006 Explorer the A/C is sending out cold air but when I turn the temperature control dial to red area for heat I don't get heated air. I dont have the thumping or clicking noice that occurs when that plastic gear/arm brakes. I put a new temperature control valve on the water line going to heater core and I noticed that valve does nothing when I turn temp control dial. I'm guessing I have a vacuum leak which is not allowing blend door to open or temp control valve to function.
Is the blend door vacuum activated and is there a vacuum manifold involved ?

Ron is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 08:44 PM.


vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

ExplorerTalk.com is in no way associated with or endorsed by Ford Motor Company.

 

Content Relevant URLs by vBSEO 3.6.0