Explorer Talk banner

1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hello all, wife’s 2019 platinum 3.5 EB AWD just turned over 19,500 miles. Has always surged at very low speeds (below 10 mph). I just thought it was the turbo. I don’t drive turbo vehicles much. It has always gotten what I thought was abysmal gas mileage (averages 15.5 in city, 17.5 on the highway). A few weeks ago, it kept displaying the little wrench icon with “see manual” message when at highway speed (70 mph). Called dealership and they said it’s probably just mileage related service intervals for little stuff. OK... then this weekend on a long trip it finally threw a check engine code that stayed on and would not go into 6th gear at all. On the my Ford app, she shows me the code (attached). Basically it says torque converter clutch is failing to engage. See dealer.

After a little research, it’s a common issue. So common, the dealer says if it is the trans, wait time is 3 months!!! Are you effing kidding man?? Oh and they have no loaners because of the backlog. Not a Ford guy, obviously, but covered under warranty or not, that is ridiculous. Anybody having similar issues or have advice on how to get out from under this POS?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
So Local Lemon laws say the dealership has 30 days to complete the repair after intake. After that, they are subject to lemon lawsuits. They finally got us an f-150 loaner after 3 days. Today was 4 and they still haven’t “officially” diagnosed the problem. Tick tock Ford....
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Finally getting the truck back tomorrow after 3 weeks. It was the torque converter. New TC, new TCM, seals and bolts. BUYERS BE WARNED.....
 
1 - 4 of 4 Posts
Top