Explorer Talk banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Is anyone else having trouble with their phone connection while driving. I've had trouble 6 months into owning this vehicle. Nobody can fix it. I'm told its a known issue. But they don't know what is wrong. This is a pricey vehicle. I'm very upset that everyone I talk with says I sound like I'm in a tin can. They hear a echo, then its fine for awhile. Then echo again .its horrible. I feel like ford doesn't care. My service rep is awesome. But all they will tell her is that its a know issue, and they don't have a ETA...any help would be appreciated.
 

·
Registered
Joined
·
23 Posts
Is anyone else having trouble with their phone connection while driving. I've had trouble 6 months into owning this vehicle. Nobody can fix it. I'm told its a known issue. But they don't know what is wrong. This is a pricey vehicle. I'm very upset that everyone I talk with says I sound like I'm in a tin can. They hear a echo, then its fine for awhile. Then echo again .its horrible. I feel like ford doesn't care. My service rep is awesome. But all they will tell her is that its a know issue, and they don't have a ETA...any help would be appreciated.
I finely bought a new head unit - because I got sick and tired dealing with the Sync radio system. Once I replaced it with a mid priced unit, I was sooo much happier and the unit was so much better.
 

·
Registered
Joined
·
30 Posts
I havecac2010 Limited. My phone works perfectly.

Check to see if you are on the current version of Sync.

Sounds like you could have a bad microphone

Astrobuf
 
1 - 3 of 3 Posts
Top