Explorer Talk banner
1 - 9 of 9 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Hello, I have a 97 Eddie Bauer with air ride suspension. I brought it into

my local Midas to have the front end inspected because I was hearing a weird clunking noise. They brought it in and took a look and everything was fine except the daytime running light module was loose and knocking around.



When I got back in it to drive it home I couldn't believe how nauseous it

felt driving around because every single little bump I hit it would continue

to bounce and bounce. It is really annoying. From doing some reading is it safe to assume that there is a problem because the mechanic didn't turn off the air ride suspension before putting it up on the hoist? Any thoughts about what I can do? It seems that the rear suspension is locked or something, it doesn't move even when putting all my weight on the bumper...



Thanks

Matt
 

·
Registered
Joined
·
170 Posts
sound's like they screwed it up..i have alot of expearance with ARC i lifted my X with ARC but what you could do is disconnect the sensor and see if the truck drop's down..i can give you pic's how to do it if needed
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #5 ·
That is the thing, the message center is working fine and gives no message. I run the system check and it is fine. I turned the air ride system off and it didn't make much of a difference, I am still bouncing down the street.... And when I take a speed bump it sounds like there is no suspension in the rear at all...
 

·
Registered
Joined
·
6,767 Posts
Shocks???
 

·
Registered
Joined
·
5,238 Posts
If they didn't really mess with much, i'd say it's all just coicidence. Besides, regardless they are not going to take the blame.
 
1 - 9 of 9 Posts
Top