Explorer Talk banner

1 - 3 of 3 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Recently i noticed, i can smell antifreeze, while driving and outside of my explorer its an 02, i looked around cant seem to see a leak anywhere and hasnt overheated, yet. I did add about a gallon of water to the resevoir, maybe 1 and a half. Anyone have any idea what to check or where to begin here? Thankyou for your help...
 

·
Registered
Joined
·
1,013 Posts
Get the engine up to temperature so the system is pressurized then you can shut it off and look under the vehicle for leaks, or if it's very hot and it's cooking away, clean spots. You are not in a generation specific forum nor did you mention your model year and which engine, but generally look around the radiator hoses, heater hoses, intake manifold, heater core valve, and especially the water pump.

If it were leaking at the heater core into the cabin and passenger footwell, I'd think you would have noticed that already.

Also look from under the hood with a strong flashlight. It may be easier to do at night in the dark. They also make a dye you can put in the coolant and then use a UV flashlight to make the leak glow.

Last possibility is it's getting sucked into the cylinders and put out the exhaust, which is worst case not only to take apart the engine to find the leak but also that if it does this for long it can ruin catalytic converter(s) and foul oxygen sensors.
 

·
Registered
Joined
·
8 Posts
Before you go to all that trouble, check your thermostat housing, the '09 plastic housing is weak, I found that ours was leaking and replaced it with a unit from Advance Auto Parts, be sure to use their discount codes when ordering! Might want to replace the rubber hoses at that time!
 
1 - 3 of 3 Posts
Top