Explorer Talk banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I'm currently experiencing a few odd occurences w/ my dash light. It started with my 4x4 lights flashing about every ten minutes. They flash about five times then go off. Also when I start up my truck my airbag light blinks a few times and then remains solid until I turn my car off. It's a 1997 explorer sport. Any help or suggestions would be greatly appreciated. Thanks in advance.
 

·
Registered
Joined
·
19,808 Posts
Ok I know that when I swapped my front seats I didn't have some of the seat wiring correctly connected, or not connected at all. One of them which I believe is wired by the female end of the seat belt connector has the airbag wiring. If that is not hooked up, then your dash airbag light will stay on all the time until you get that corrected. You can try resetting the battery, whatever you want but unless that is connected (the airbag wiring) it will stay on.



As for the 4x4 lights flashing, I'm not really positive as to what might cause that problem. I know I've certainly heard of it before in fact it may have even happened to me when I used to take my truck offroading.



But one thing I strongly do recommend is taking your truck to even a local auto shop and have them do the plug-in diagnostics. Rather than you guessing what is what, they will be able to tell immediately what the problem is and they can repair it right away.



Hope this helps and good luck getting your X back in working condition!
 

·
Registered
Joined
·
1,254 Posts
At a car show i was at. I took out the fuse going to my dome lights, it was also for the 4X4 switch, so when i started my car the 4X4 light was flashing. So it could be a blown fuse
 
1 - 4 of 4 Posts
Top