Explorer Talk banner
1 - 5 of 5 Posts

·
Registered
Joined
·
40 Posts
Discussion Starter · #1 ·
Hello all,



Has anyone out there had any problems with their power windows? The reason I ask is that I seem to have a problem with my rear windows.

Earlier tonight, I made a trip to the grocery market and when I got back in my X, the p/s rear window wouldn't work. The other 3 worked. After a few minutes of fidling around with the switches I finaly got it to work. This isn't the only time this has happened though. About a week ago the d/s rear window did the same thing. It seems as if I've got a loose connection somewhere. I think I'm going to take it back to the dealership
. What do you guys think?
 

·
Registered
Joined
·
19,808 Posts
May be as "simple" as a faulty motor. Take it to your local Ford dealer (they are really the only ones that can really fix it) and have them inspect it. Since you have a 03 I am assuming it is definitely under warranty. All the more reason to just take it in and have it fixed.
 

·
Registered
Joined
·
64 Posts
May be as "simple" as a faulty motor. Take it to your local Ford dealer (they are really the only ones that can really fix it) and have them inspect it. Since you have a 03 I am assuming it is definitely under warranty. All the more reason to just take it in and have it fixed. ?


what he said....



...except for the faulty motor (unless you're lucky enough to have two faulty motors). Do the rear switches work? If it is a loose connection, I would guess that it's on the front d/s controls.
 

·
Registered
Joined
·
40 Posts
Discussion Starter · #4 ·
Yeah, I guess it's my only option. Has anyone else had any problems with theirs?



It just ticks me off though-my X has barely 7000 miles on it.
 

·
Registered
Joined
·
1,254 Posts
I had the same prob in my 95 XLT last summer. It was like a 2 time freak thing and I did nothing, and its been fine since. If you got warrenty have it checked
 
1 - 5 of 5 Posts
Top