Explorer Talk banner
1 - 1 of 1 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
The noise started several months ago. Was noticeable once I got above around 30MPH. Came from the drivers window area right at head level and slightly behind me. I changed the door weather seals but that had no effect. The fix: lowered the window completely, took the glass weather strip out - easy to do just pull down from the top center then pull it out of the back channel. That reveals the four securing screws for the front of the beauty plate (mine is gloss black and houses the entry keypad). The beauty plate has a "C" edge on the back so you must be careful if you are going to remove it to clean and inspect the underside - not necessary for the fix. On my rig, all four of the screws were there, but the plastic mounting holes where the screws go thru were shattered and no longer part of the beauty plate. Note: before you take the screws out, be sure to put something along the window opening to prevent the screws from dropping down inside the door should you lose control of one the little buggers. I fabricated a custom washer (cut the sides off a small fender style washer with a hole that just fit the screws) that fit into the window channel and once tightened held the beauty plate firmly in place - tight against the door's metal frame. After I put the window weather strip back in, it was obvious that the trailing edge of the window weather strip was designed to overlap the leading edge of the beauty plate. Without the window channel screws to keep the beauty plate in place it had move outward enough to open a wind gap. Just checked the fix and the noise is gone.
 
1 - 1 of 1 Posts
Top