Explorer Talk banner
1 - 11 of 11 Posts

·
Registered
Joined
·
666 Posts
Discussion Starter · #1 ·
Here are my new subs .. I LOVE THEM! I had them before in my Xterra, but sold them when I got the stang. Im glad I got them back now. WOOT!



BTW- The amp is amazing! (The HIFONICS logo even lights up!)



The subs are 2-12W3V2's in a JL Audio H.O Box.







 

·
Registered
Joined
·
7,812 Posts
Very nice setup!!!!!
I suggest putting both under the back seat.
 

·
Registered
Joined
·
7,812 Posts
yeah is should get plenty especially if you have the rear air. Just put in on the floor setting and on speed 1 or two to move around the air.
 

·
Registered
Joined
·
7,812 Posts
When people sit back there tell them not to mess with the air controls or you'll f**k them up.:)
 

·
Registered
Joined
·
19,808 Posts
Well for one thing, and I forget the exact reason (I read it over fast) but mounting your amp on your sub box is a huge no-no. Yes I realize how many shops do this. And no it is not OK.
 

·
Registered
Joined
·
7,812 Posts
The reason it's a no-no is because it sends shock waves and vibrations through the amp. Some people say yeah but driving around rattles around the amp. True, but not in the same way. Having the amp on the box will just rattle the amp to pieces.
 

·
Registered
Joined
·
666 Posts
Discussion Starter · #11 ·
I bet the set up HURTS!!! ?



Kinda like having a Band in the truck with you!

?:rockband:


It sure does man! But it will hurt even more in about 1 week! I just ordered JL audio XR Compnents! WOOT!!!!
 
1 - 11 of 11 Posts
Top